Just got a 2003 Berlingo Electrique (with problems!)

If you own a Electrique or any of the other PSA range of vehicles then look here for your answers and post your questions or general views here
Grumpy-b
Posts: 991
Joined: Sat Dec 01, 2007 12:06 pm

Re: Just got a 2003 Berlingo Electrique (with problems!)

Postby Grumpy-b » Mon Jan 25, 2016 3:11 pm

No you could never get the temp sender from Citroen, it was only ever available as part of the top battery box. Replacement.
Remove the 12v battery
Remove the rear battery box fuse,
Remove main controller.
Disconnect and remove the Motor cooling fan.
Disconnect the watering manifold .
Disconnect the battery connections using a good sharpe not worn, torx screwdriver. Its easy to shred the tops of these.
Remove the three bolts holding the battery box,
Using some bits of 4x2 timber slide the box forward, as you do put your had behind and unclip the watering tubes from the rear of the battery.
Remove the clips around the two halves of the box, ease off the top,
Undo the connections to the passenger side front cell, this is where the sensor is located. lift cell so you can prise out the
sensor.
Put it into a jiffy bag and send it to me.
I send you an invoice,
You send me £40 by bank transfer.
I rebuild your sensor and send it back to you.
Reverse procedure.

willfromsussex
Posts: 84
Joined: Sun Oct 04, 2015 3:45 pm

Re: Just got a 2003 Berlingo Electrique (with problems!)

Postby willfromsussex » Mon Jan 25, 2016 9:15 pm

My goodness! .
Sometimes I wish Nissan or Honda had built these, then the part would be out in 2 minutes. Do you have a pic of the sender? Do you replace the sensor and splice the wires to the original connector or something as presumably the actual sensor itself is sealed.

Do you do exchange ones (so I can put car back together instantly rather than waiting several days) ta.

Would you consider it safe to charge the vehicle with this sender disconnected?

What would you charge to do the repair if I brought the vehicle to you?

Cheers.

Grumpy-b
Posts: 991
Joined: Sat Dec 01, 2007 12:06 pm

Re: Just got a 2003 Berlingo Electrique (with problems!)

Postby Grumpy-b » Tue Jan 26, 2016 6:26 am

Since the part is retained in the side of the battery, I remove the guts that are sealed in the small sensor and replace the innards, Its not a std off the shelf component, I havnt done exchange since another BVS member failed to return the item, so I then had no exchange units.
You can simply put a resister into the connector , that spoofs the controller into thinking its reading around 30c and is happy.
You could do the job in the time it would take you to get up to me. its really not that difficult. Just follow the steps I posted.

willfromsussex
Posts: 84
Joined: Sun Oct 04, 2015 3:45 pm

Re: Just got a 2003 Berlingo Electrique (with problems!)

Postby willfromsussex » Sat Jan 30, 2016 12:01 am

Ok. I wonder if that being duff is why the radiator fan is on the whole time on the red van, even while charging the battery.
I have never seen the fan come on the white one, and after having a look.. i notice someone had unplugged it! Hmm .

Hope you don't mind if I ask a couple more Qs.

When is the motor air blower fan meant to come on? Never noticed it on on either van.

Red vans front brakes need overhaul, are the discs same as all petrol or diesel berlingo / Partner, or is there a certain spec to ask for.

Grumpy-b
Posts: 991
Joined: Sat Dec 01, 2007 12:06 pm

Re: Just got a 2003 Berlingo Electrique (with problems!)

Postby Grumpy-b » Sat Jan 30, 2016 9:05 am

Radiator Fan is on because the controller has decided it or the battery pack is too hot. Charging is when it normally comes on.
Motor fan seems to come on at all sorts of times, some all the time. Never worried too much about it, but again there is a motor temp sensor, that probably controls it.
Discs are std solid non vented, mk1 brakes. I do have some in stock, but postage would be heavy . Pads as well.
All the brake parts are std Mk1. Later Mk2 did have the vented brakes, and these are different to the mk1 vented brakes. both disc dimensions and caliper /pads.

willfromsussex
Posts: 84
Joined: Sun Oct 04, 2015 3:45 pm

Re: Just got a 2003 Berlingo Electrique (with problems!)

Postby willfromsussex » Sat Jan 30, 2016 10:33 pm

Yes i noticed the vented ones on my 2003 . i had it up on my ramp cleaning the underside because it is quite low it scoops mud into all sorts of places when I drive down my farm track!


Return to “Citroen Berlingo Electrique or other PSA vehicles”

Who is online

Users browsing this forum: No registered users and 6 guests