Berlingo complete loss of power (temporarily!)

If you own a Electrique or any of the other PSA range of vehicles then look here for your answers and post your questions or general views here
bustodian
Posts: 4
Joined: Sun Jun 26, 2011 6:31 pm

Berlingo complete loss of power (temporarily!)

Postby bustodian » Mon Jan 12, 2015 6:14 pm

A new one on me! My Berlingo hasn't put a foot wrong in five years. Now a problem. Complete loss of power for a fraction of a second. Stop light only and then park, restart and it's fine. It's got worse over two weeks , sometimes the fault light glows so then park up reset by fuse removal and away we go. The fault is happening with greater frequency. I've removed each battery box and every connection is sound. Fuse holders and fuses seem ok - one holder showed signs of carbon and melting - I've changed that. Has anyone any ideas on this one?

User avatar
timpootle
Posts: 1361
Joined: Wed Mar 14, 2007 12:13 pm
Location: Chorlton-cum-Hardy, UK

Re: Berlingo complete loss of power (temporarily!)

Postby timpootle » Wed Jan 14, 2015 6:46 am

Mine did that while I was on the motorway with no controller cooling. Have you checked the water level in both sides of the radiator, and listened to the pumps whirring?
Tim Crumpton

User avatar
Flying John
Site Staff
Posts: 334
Joined: Fri Jul 14, 2006 5:24 pm
Location: Kent

Re: Berlingo complete loss of power (temporarily!)

Postby Flying John » Fri Jan 16, 2015 4:57 pm

When was th last time you inspected the brushes.

Could be broken/worn brush, or brush(s) sticking in holders. Does it tend to do it under high load.

Grumpy-b
Posts: 991
Joined: Sat Dec 01, 2007 12:06 pm

Re: Berlingo complete loss of power (temporarily!)

Postby Grumpy-b » Fri Jan 16, 2015 7:07 pm

Sounds like brushes.
I have them in stock if needed.

Grumpy-b

bustodian
Posts: 4
Joined: Sun Jun 26, 2011 6:31 pm

Re: Berlingo complete loss of power (temporarily!)

Postby bustodian » Sun Jan 18, 2015 5:44 pm

Thanks for your replies. Pumps ok. Could it be the brushes? It's true that I have never changed them. Just looked into the motor and it's clean and not dusty. I'm running out of ideas......I'll try the brushes.

bustodian
Posts: 4
Joined: Sun Jun 26, 2011 6:31 pm

Re: Berlingo complete loss of power (temporarily!)

Postby bustodian » Sun Jan 18, 2015 5:46 pm

Grumpy! How do I contact you?


Return to “Citroen Berlingo Electrique or other PSA vehicles”

Who is online

Users browsing this forum: No registered users and 7 guests