More Belingo van troubles , charging not intialising ?

If you own a Electrique or any of the other PSA range of vehicles then look here for your answers and post your questions or general views here
Grumpy-b
Posts: 991
Joined: Sat Dec 01, 2007 12:06 pm

Re: More Belingo van troubles , charging not intialising ?

Postby Grumpy-b » Sun Mar 09, 2014 8:41 pm

It sounds like a common charger problem that I have had on a lot of Blingos, charge starts then after a few seconds shuts down, it will repeat ad infinitum if you un plug and start again.
A job for Evan,
Rear pack showing average of 5.8+v suggests that one or two cells are weak in that pack.

Grumpy-b

jamesingram
Posts: 46
Joined: Thu Dec 12, 2013 3:30 pm

Re: More Belingo van troubles , charging not intialising ?

Postby jamesingram » Mon Mar 10, 2014 7:05 am

thanks Grumpy ,
Yes EVlite still has know effect .
Could anyone PM me Evan details. Googling around he seems to be less active in the last few years and cant find contact details or web activity, noticed he used to post on greenbuilding forum several years back also re EV.
Estimated cost would be useful also.
High-end mentioned in another thread Polish guys who could potentially refurb charge controller ??

The batteries are right down now , any way to get some charge in them whilst it sits idle to keep them in shape (if necessary ??)
and finally where is the charge controller ?? :shock:
and finally, finally , where would any error message appear on EVlite.
read on threads about them , not sure which screen there on ??
thanks again

Grumpy-b
Posts: 991
Joined: Sat Dec 01, 2007 12:06 pm

Re: More Belingo van troubles , charging not intialising ?

Postby Grumpy-b » Mon Mar 10, 2014 9:01 am

I am still in contact with EVan. I will ask him for you.
No error on Evlite
Charger is all part of the big Alloy box, so thats what you send. Its cheapest by Hermes, by about a half Royal Mail.At around £16 each way.

Grumpy-b

jamesingram
Posts: 46
Joined: Thu Dec 12, 2013 3:30 pm

Re: More Belingo van troubles , charging not intialising ?

Postby jamesingram » Mon Mar 10, 2014 8:12 pm

thanks again .

User avatar
ChrisB
Posts: 4657
Joined: Fri Jul 14, 2006 11:33 am
Location: Hampshire on the Southcoast
Contact:

Re: More Belingo van troubles , charging not intialising ?

Postby ChrisB » Tue Mar 11, 2014 8:47 pm

jamesingram wrote:12V battery seems fine , all lights etc. work fine and bright..


Doesnt always mean the 12v is happy as the DC-DC will keep that happy, I dont know the relationship but to make sure its not the 12v Aux causing any issues I would either find a known good battery and swap it out or temporarly get a set of jump leads and jumper it to make sure the 12v is REALLY OK and not just showing as OK because the DC-DC is keeping it that way, gota be worth a bash

ChrisB
I reject reality and substitute my own !!!!!!

jamesingram
Posts: 46
Joined: Thu Dec 12, 2013 3:30 pm

Re: More Belingo van troubles , charging not intialising ?

Postby jamesingram » Wed Mar 12, 2014 11:41 am

i'll give it a go cheers chris

Grumpy-b
Posts: 991
Joined: Sat Dec 01, 2007 12:06 pm

Re: More Belingo van troubles , charging not intialising ?

Postby Grumpy-b » Sun Mar 23, 2014 4:46 pm

No response from Evan, but I have put a new (Yes still in the PSA box) Complete controller for sale on the for sale section. I have spent as much as the sale price on getting Evan to repair controllers in the past (my original one cost around £800 to repair)
Its on as an exchange, so I can get it repaired at leisure and hold another spare for one of my long term commercial use customers. (The heavily modified Blingos are used for camera tracking work)

Grumpy-b

jamesingram
Posts: 46
Joined: Thu Dec 12, 2013 3:30 pm

Re: More Belingo van troubles , charging not intialising ?

Postby jamesingram » Mon Mar 24, 2014 9:15 pm

Grumpy ,
I'm keen
I've pm you my email
thanks

jamesingram
Posts: 46
Joined: Thu Dec 12, 2013 3:30 pm

Re: More Belingo van troubles , charging not intialising ?

Postby jamesingram » Sun Mar 30, 2014 8:55 pm

So , no luck so far on a new/refurbed Segem unit, Grumpy's currently looking at his possible spare kit for me.
Aany one got any bright idea to get power into the batteries ?
I run them down to see if I had dodgy cells and am now a bit paranoid that that if they sit empty this may cause a problem . Is it ?
Could I link them up to a trickle charge by-passing the controller by some means or is this just a bad idea.

Highend mentioned some guys in Poland that can refurb charge controllers , any more info on that highend ?

thank again.

User avatar
timpootle
Posts: 1361
Joined: Wed Mar 14, 2007 12:13 pm
Location: Chorlton-cum-Hardy, UK

Re: More Belingo van troubles , charging not intialising ?

Postby timpootle » Sun Mar 30, 2014 8:59 pm

I don't think NiCads mind sitting flat in storage . Don't worry on that front, unless anyone knows better.
Tim Crumpton


Return to “Citroen Berlingo Electrique or other PSA vehicles”

Who is online

Users browsing this forum: No registered users and 7 guests